読者です 読者をやめる 読者になる 読者になる

てきとうなメモ

本の感想とか技術メモとか

incompatible character encodings: UTF-8 and ASCII-8BIT

Ruby

ruby 2.0 + rails 3.0のアプリでタイトルのようなエラーがでた。ググるとパッチが見つかるけど、自分の場合は、DBアダプタがmysqlになっていて、それがちゃんと処理していなかったようだ。mysql2に変更したら解決した。