読者です 読者をやめる 読者になる 読者になる

てきとうなメモ

本の感想とか技術メモとか

RHEL 6.5でruby 1.8.7-p374のコンパイルに失敗する

Ruby RHEL

このバグ引いてしまったっぽい。opensslのconfigureのオプションが変更されてno-ecがなくなってec系の関数もコンパイルしようとしているのだが、no-ec2mは付けたままでかつno-ec2mで除外される関数も使っちゃっていたので、エラーになったということらしい。

リンク先のパッチをあてればなおる。